注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

胡益兵的博客

新的岗位,新的方向,新的使命,stem教育进行中。

 
 
 

日志

 
 

[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题  

2016-11-14 00:18:16|  分类: App Inventor |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
使用老巫婆提供的2016版App Inventor安装程序(AppInventor离线版2016安装程序),ai伴侣版本是2.36cdk1
[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题 - hyibing - 胡益兵的博客
网上找了很多版本的ai伴侣程序安装,均提示版本过期了要去升级(比较多的是2.11版)并自动退出模拟器。
[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题 - hyibing - 胡益兵的博客
但是老巫婆的版本没有提供升级包
[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题 - hyibing - 胡益兵的博客
 
问度娘解决办法,找到这个http://blog.sina.com.cn/s/blog_545fe4130102w81j.html
看来要自己找高版本了,于是翻墙到App Inventor官网的在线编程,它到是提示有模拟器有升级包并可以在线升级,版本是2.39
升级完后启动老巫婆汉化版并连接模拟器,系统仍然提示版本过期,但是不影响在线使用。
虽然不影响使用但是总提示各版本过期心里怪怪的。
后来找到老巫婆提供的模拟器下载AIStarter,但是安装完了仍然是2.11版,卸了再装还是2.11版不能使用。
心里不死心,再到学校安装,结果发生了“灵异事件”:同样的安装文件,在教师机上安装显示是2.11版不能使用,但是在学生机上安装显示的却是2.36cdk可以正常使用,见了鬼了。
装了删,删了装,折腾了一天终于搞清楚怎么回事了:问题出在了这里:
先要卸载原来的系统识别的2.11版模拟器程序,并显示隐藏文件
[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题 - hyibing - 胡益兵的博客
然后进入如下目录,会发现还有文件没被删除,如果不删除他们,不管你装的是什么版本它只认2.11版
[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题 - hyibing - 胡益兵的博客
 
[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题 - hyibing - 胡益兵的博客
 然后再安装老巫婆的AIStarter 搞定!
[解决]ai模拟器(AIStarter)安装版本错误无法运行的问题 - hyibing - 胡益兵的博客

小结:如果装过低版本的模拟器,即便卸载了装新版本,由于卸载不干净系统仍然只认为装的是低版本,只有在卸载完成同时将相关目录清理干净后再安装,系统才能识别新的版本,不知道这是不是一个bug呢?
  评论这张
 
阅读(256)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018