注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

胡益兵的博客

新的岗位,新的方向,新的使命,stem教育进行中。

 
 
 

日志

 
 

[解决]moodle 环境检查php官方加速器opcache未安装错误  

2014-12-04 12:51:05|  分类: linux应用 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
moodle安装时间检查php环境提示php_setting opcache.enable PHP配置应安装,他是php的官方加速器
PHP字节码缓存提高性能且降低对内存的要求。Moodle完全支持并建议使用OPC缓存扩展

补充安装方法如下:
wget http://pecl.php.net/get/zendopcache-7.0.3.tgz
tar zxf zendopcache-7.0.3.tgz
cd zendopcache-7.0.3/
/usr/local/php/bin/phpize
./configure --with-php-config=/usr/local/php/bin/php-config
make
make install


/usr/local/php/etc/php.ini里直接加到底部,官方建议参数
zend_extension= /usr/local/php/lib/php/extensions/no-debug-non-zts-20100525/opcache.so
opcache.enable = 1
opcache.memory_consumption = 128
opcache.max_accelerated_files = 4000
opcache.revalidate_freq = 60
 
; Required for Moodle
opcache.use_cwd = 1
opcache.validate_timestamps = 1
opcache.save_comments = 1
opcache.enable_file_override = 0
 
; If something does not work in Moodle
;opcache.revalidate_path = 1 ; May fix problems with include paths
;opcache.mmap_base = 0x20000000 ; (Windows only) fix OPcache crashes with event id 487
 
; Experimental for Moodle 2.6 and later
;opcache.fast_shutdown = 1
;opcache.enable_cli = 1 ; Speeds up CLI cron
;opcache.load_comments = 0 ; May lower memory use, might not be compatible with add-ons and other apps. 

安装完成后可从moodle后台服务器-环境检查报错不再出现。也可查看phpinfo
[解决]moodle 环境检查php官方加速器opcache未安装错误 - hyibing - 胡益兵的博客
 
  评论这张
 
阅读(1066)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018